Back to overview
Resolved

Production Server Maintenance

Aug 27, 2026 at 2:30am UTC  –  Aug 27, 2026 at 3:00am UTC
Affected services
Dashboard Admin
Dashboard Merchant
Checkout Page
Core API

Resolved
Aug 27, 2026 at 3:00am UTC

Maintenance ended

Created
Aug 27, 2026 at 2:30am UTC

Scaling up master Node on Production